Yes, Makro is compatible with WordPress 5.5 and higher versions.

Axiomatic Web Solutions Pvt. Ltd. Would you like to receive notifications on latest updates ? No Yes